JavaScript is disabled. For a much better experience, please allow JavaScript in her browser before proceeding.

You are watching: Dodge ram check gauges light battery


First actual cold night, if that means anything. Alarm sounded after 5 secs of beginning and inspect gauges light come on and also the only gauge that was not functioning was the battery gauge. Journey 50 miles. After preventing for approx. 30 minutes, started truck and also everything fine climate it taken place again. Engine many warm. The gauge only registered around 10V rather of the usual 14V before it stop working.Any ideas? every little thing is good otherwise.Woodyjrwoody52
*

Could be a the majority of things indigenous dirty battery terminals, loose fan belt come a poor alternator. I would begin by check the voltage in ~ the battery through the eng. Running, v the irradiate both on and also off. After ~ driving the 50 miles the battery got enough charge come shut the light/alarm off and then the came ago on after driving a little, choose it to be loosing the charge while driving. Might be a poor battery also.

See more: Alpha Kappa Alpha Pinky Finger Meaning, Alpha Kappa Alpha


I view what friend mean. The light continued to be on all the time till I stopped the truck and turned it off for around 30 minutes. Then started it ago up come head home and the light was briefly turn off for 10 seconds and also came back on. I"ll begin with the easy and inexpensive checks first. Once I gained home i was idling and turned on every electrical, lights/heater/etc. And also lights did not dim. Through two batteries it can be hard to tell. I don"t have to spend no longer money right currently if ns don"t have to. A lot on my plate. Thanks!
CHeck Gauges instrument light on then turn off then on climate off
I will certainly apologize right now due to the fact that I have probably posted wrong.***I have actually come to believe the "Check Gauges" light is one indicator that even trained mechanics perform not fully understand.On mine 2007 Dodge ram 1500 SLT 4.7 Flex Fuel I have actually an intermittent check Gauges problem.The instrument cluster "Check Gauges" light will stay on after engine starts. The Oil push gauge will not read.Turn turn off engine and also re-start engine and also the "Check Gauges" light will go off and stay off and gauges will suggest normal levels.This is a repeatable pattern.Start engine and "Check Gauges" light will remain on.Turn off engine and re-start engine and "Check Gauges" light will go out with normal indications.I have been told numerous items could be the problem however cannot small them down to any one item leading to problem.One time if driving the "Check Gauges" light come on and all gauges failed to indicate.I"ve to be told:Short in wiringInstrument swarm badOil sending out Unit badKey Cylinder badIgnition switch badThe just thing that is particular is the trouble exists in between the front bumper and the behind bumper.If over there is anyone reading this that has an answer, or a great solid guess, I would certainly appreciate hearing it.By the way, other than this aggravating problem the truck runs as good as ever also though it has actually 155,000 mile with only the air compressor being replaced.